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1. Magnifi Integration 
Important notice: To use the Magnifi integration feature of TubePro 5.4, you need to have Magnifi 4.5 
or higher. 

1.1 Prepare Magnifi 

Open Magnifi and create your project folder, inspection folder and setup. Make sure that the setup is 
located inside the current inspection folder.  

 

 

Also, the filename type, under the acquisition section, needs to be set to the Row, Col option. 
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To allow the Magnifi integration click on the preferences button on the left-hand side of the backstage. 
In the System tab, click on the TubePro 5.3 integration option on the bottom of the menu. 

 

1.2 Preparing the tube list 

Go to the Magnifi tab in TubePro and click on Select Inspection Folder and select the same inspection 
folder that you used previously in the Magnifi software. 
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Once your bundle has been mapped correctly, unselect the tubes, go to the Magnifi tab and click on 
the Update Magnifi button. Once you do, a message will appear asking you if you want to send the 
complete tube list to Magnifi.  

 

If you click Yes, all the tubes will appear in your Magnifi tube list. If you click No instead, you can select 
the specific tubes you want to have in Magnifi using the options in the SELECTION-ADV tab under the 
MAP – ADVANCED subsection or by simply selecting the tubes you want to inspect with the tools 
available in the SELECTION tab.  

 

Here is a short description of the available options in the SELECTION – ADV tab: 

• Incl. all Outside Tubes: Includes the tubes located on the outside of the bundle. 
• Incl. First/Last each Row: Includes the first and the last tube of each row of the bundle. 
• Incl. First/Last each Column: Includes the first and the last tube of each column of the bundle. 
• Excluded Plugged Tubes: Excludes every tube marked as Plugged from the selection. 
• Distribute Selection Evenly: Prevents from selecting a cluster of tubes in a corner. 
• Distribute by Increments: Distribute selection by row and column increments. 

Once you have selected the desired options, you can set the minimal percentage of the tubes in your 
bundle you want the software to select in the Settings portion of the ribbon. If you selected the 
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Distribute by Increments option, you can set the increments for the rows and the columns in the 
Increments subsection. 

Then, when all the options are set accordingly, click on the Select Tubes option and the software will 
select tubes in your bundle whilst respecting the options you’ve selected. You can save this selection of 
tubes using the Write LST button so you can select the same tubes in further point in time using the 
Load LST button. 

Once the selection is correct, go back to the Magnifi tab to click on the Update Magnifi button who will 
send the selected tubes as a tube list to Magnifi. 

 

If you have unselected the tubes in TubePro once they’ve been sent to Magnifi, you can re-select the 
same tubes from your tube list using the Show Tube List in the Magnifi tab. 

 

Once the tubes have been sent to Magnifi, all the tubes will disappear from the INSPECTION DATA list. 
From that point on, that DATA list will only be populated when a defect is added to the report in 
Magnifi. Even still, the 2d and 3d views of you bundle will remain the same. 
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1.3 Bringing Magnifi data to TubePro 

To receive the Magnifi data of your tube list you can use the Get Magnifi Data button under the Magnifi 
tab which will import the data of a specified section once. You can choose the section to import using 
the dropdown menu next to the button. 

 

 

Alternatively, you can automatically send the Magnifi data to TubePro as soon as it is acquired with 
Magnifi. To do so, you need to activate the Monitor Changes button in TubePro. It is activated when the 
button is highlighted in blue. 

 

The Monitor Changes button when it isn’t activated 

 

 

The Monitor Changes button when it is activated 

 

1.4 Inspection data 

After mapping your bundle, all the tubes should appear in the INSPECTION DATA subsection. 
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Once the link with Magnifi is created all the empty tubes will be removed from the spreadsheet leaving 
only the tubes with relevant information attached to them. The spreadsheet will update and add the 
necessary tubes as they are imported from Magnifi, either by the Get Magnifi Data or the Monitor 
Changes buttons in the Magnifi tab. 

 

 

There are a few functions available to the user to manipulate the data in the spreadsheet. Those 
functions can be found in the DATA tab. 

 

Here is a rundown of the different functions: 

• Fill Selected: Fills all the values in the selected column with a new value. 
• Fill All: Fills all the values possible to the selected value. 
• Clear: Clears all the values in the selected column. 
• Remove All: Deletes all the rows in the spreadsheet. 
• Add Row: Adds a single empty row. 
• Delete Selected: Deletes the currently selected row. 
• Duplicate: Duplicates the currently selected row.  
• Insert: Adds a new column. 
• Remove: Deletes the selected column. 
• Properties: Allows the user to edit the properties of the selected column. 
• Set ‘All Inspected’: Sets all tubes to Inspected (0% wall loss). 
• Set ‘All Not Inspected’: Clears all inspection data and sets all the tubes to Not Inspected.  
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• Set Code for All: Sets the code for all the tubes to a specified code by the user. 

Please note that when you update a value in the spreadsheet, you lose the original value from Magnifi 
which can only be regained by re-importing the data from Magnifi using the Get Magnifi Data function 
in the Magnifi tab. 

 

2. Multiple inspection data in one report 
In TubePro 5.4, you can now add multiple inspections data in your report to help compare the result of 
your analysis to other set of data from the same bundle. 

2.1 Creating another inspection 

Before adding the report data, a new inspection must be added to the Project. To do so, go to the 
Project tab, click on the Inspections button and then click on the Add Magnifi Inspection option the 
dropdown menu. 

 

Once you click on the option, a window will appear where you can enter information related to the new 
inspection. 
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To switch between inspections, click on the Inspections button under the Project tab and select your 
desired inspection in the Select Inspection subsection. 

 

You can see which inspection is opened by the word Active in parenthesis next to the currently opened 
inspection. 

To populate your newly created inspection you can either add new data with Magnifi, the same way we 
added data previously in this document, or by importing data from an older inspection.  
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To import data directly, click on the Import Data button under the Project tab and click on either 
Import & Replace or Import & Append. For a given tube, Import & Replace will overwrite the existing 
data with the new import while Import & Append add the new information as a new defect for that 
tube. Once you click on either of the two options, you need to select your datafile. 
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3. Creating legends 

3.1 Basic legend 

To create a new legend, go to the Project subsection of the Project Browser, click on the New Report 
Elements and select the Legend option in the dropdown menu. You will need a legend for each of the 
inspection that you want to display. 

 

 

Then, a window will appear which will allow you to customise your Legend. Here you can add content 
to your legend and link the legend to a given inspection. To do so, click on the arrow next to the 
inspection textbox and choose your desired inspection. 
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To add contents about your bundle, click on the add button on the right-hand side and click on the 
items you want to add to your legend. 

 

Once the legend is complete, we recommend saving it for later use. 
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3.2 Legend with ID/OD defect discrimination 

Legend can be set to count separately different tubing defect. In this example, a Legend will be created 
to differentiate ID and OD defects. 

I. To create a Legend, navigate to the left-side Project Browser, select the Project tab, click 
on the Create icon and select the Legend item from the drop-down list. 
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II. When creating the legend, make sure that in the Data subsection the following Data 
Structure is selected: TubePro5TubeSection 

 

If the Legend that is being created needs to be assigned to a specific data set, it is 
important to select that Inspection from the drop-down list: 

 

III. Create a new Legend line, select one that is similar and click on Duplicate, or click on 
Add. The COUNTER item is the standard legend item that is used most of the time. 

IV. Select the newly created legend item and click on Edit. 
V. When in the Edit Counter window, the first thing that is important to do is to make sure 

the Name is unique. For this example, the “OD counter” name is 0-20 and the newly 
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created “ID counter” is set to 0-20-ID. This naming structure needs to be coherent 
throughout the Legend. 

VI. To discriminate ID and OD defects, a new Conditions to be met needs to be added. First 
click on the + sign, then click on Side: 

 

VII. For this example, the suggested condition should be [Side] begins with ID: 

 

VIII. To make sure they can be visually differentiated on the drawing, the icon needs to be 
changed. This can be done on the bottom section. For this example, a non-filled square 
from the same colour as the OD indication has been chosen: 

 

IX. Once the ID indications are set, the other items in the legend also need to be updated so 
they only consider the OD indications. The same editing steps need to be taken so the 
Side is used in the Conditions to be met. 
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X. Once finished with the new legend, it can be added to a Drawing. For it to be properly 
displayed, a new 2D Map needs to be created: 

 

XI. When setting up the 2D Map, specify the newly created legend in the General settings: 
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4. Creating drawings with multiple inspections 
When using multiple inspections and legends, it’s important that the proper 
links are created between the legend and the different drawings. 

The first step in creating your drawing is to create the elements of your 
drawing. In this example, we will create a view of our tube map. To start off, 
click on the Project tab in the Project Browser then click on the New Reports 
Element and select the type of element you want to create. 

 

 

 

 

 

When you select the 2D Multiple Tube Section View to create the view of your tube map, a window will 
appear to ask you to name this view.  
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Enter the name of your element and click Ok. This element will now be available in the Project tab in 
the Project Browser. Simply drag and drop the element to add it to your drawing. 

 

Once the element is placed in your drawing you can link it to your legend, so it’ll display the defects in 
your bundle. To do so double-click on the element to open the Multi-Section View and go to the View 
tab. Click on the arrow next to the Legend textbox to select the desired legend. 
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Here’s an example of a completed drawing with a 2D tube section view and its legend: 
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5. Creating a comparison of tube sheet maps 
If you want to compare multiple inspections on the same tube sheet, you need to create the different 
inspections and populate them with the desired data. As mentioned previously, you then need to create 
a legend for each of your inspections and link them with the proper inspection. Simply add your new 
elements side-by-side in a drawing and link it to its legend.  

 

 

You can then save your drawing and add it to your report. 
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6. Using the new Snapshot feature 

8.1 Snapshot overview 

In order to improve the stability and lower the file sizes, the workflow to create 3D model views has 
been slightly changed. The following steps will guide you through the new Snapshot editor to create 
the 3D views used in drawings and the report. 

1. Accessing the Snapshots editor window 
1.1 From the DRAWINGS or DOC – REPORTS page, select the Project tab in the right-side 

Project Browser. 
1.2 In this tab, double-click on the Default-Default item located in the 3D Model Snapshots 

section. 
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8.2 Snapshot editor menu overview 

The Snapshot menu is a window opened over the main window. Here is an overview: 
 

 
 
In this window, the 3D bundle will be edited to create the desired views. It is composed of 3 
sections: 

A. Model features: In this section, the different features of your 3D model can be 
hidden/shown. It behaves the same way as the menu in the 3D MODEL section. It’s 
important to note that the changes made in this section are related to a specific Snapshot. 
All changes are independent. 

B. Snapshots item: This section allows you to copy, create, edit and save the snapshot 
created. 

C. 3D model view: Like in the 3D MODEL section, the exchanger is positioned to create the 
desired view. 
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8.3 How to create Snapshots 

Here are the steps to create Snapshots: 

1. When the Snapshot editor is opened for the first time, the Default view is selected; 

2. In the Snapshot section, click on Add; 
3. Enter a relevant name for your snapshot; 
4. Select the newly created item. Make sure it’s highlighted in blue 
5. In the 3D model view, perform any scale and displacement desired; 
6. To improve the appearance of your snapshot in your report, it is possible to edit the Handles 

around the model. These handles are highlighted in the picture below: 
 

 
  

When sizing the view with the Handles, the defined perimeter is the size of the view that will be 
apparent once used in the DRAWING and DOC-REPORT tab. The dimensions set with the 
handles are saved with the snapshot. 

7. Once the view is positioned correctly, save your snapshot and close the editor. Your snapshot 
will now be available in the right-side Project Browser. 
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7. Importing data from a report 
TubePro can import multiple types of inspection reports coming from various acquisition software. 
The following procedure will guide you through the steps to activate different Import Structures. 

Prior to importing, it is important to know that there needs to be a tube sheet created in your 
project (MAP section) so the tube list can be populated with indications in the INSPECTION DATA. 

7.1 Adding an Import Structure 

1. Go to INSPECTION DATA left tab 
2. In the DATA ribbon, click on the Edit icon: 

 

 
 

3. Click on Add button, then Load from File button: 
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4. In the now opened window, navigate to (user’s computer) -> Documents -> ISS.T5 -> Import 

Structures. 
5. When in the proper folder, the Import Structure Template needs to be selected from the 

bottom right drop-down list.  
6. Select the desired ISTPL file depending on the software you are using and click Open 

 
 

7. Close the window. 
8. In the Data ribbon, click on Import Replace or Import Append 
9. In the opened window, choose the file location and select the proper import structure from 

the drop-down list in the bottom right corner. 
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10. Then select your desired Report file and open it. The data will now appear in the INSPECTION 

DATA. 
 

7.2 Assigning the acquisition data columns to the data columns in 
INSPECTION DATA 

Sometimes, all the columns read by default by TubePro are not everything you are looking for. To 
assign a specific value to a specific column in the report, here are the steps to take: 
 
1. Open the data file that you would like import. In this example, we will be selecting the data 

from a Corestar MDB structure. 
2. Identify the columns that you want to add to the INSPECTION DATA. In the procedure, we want 

to add the measurement method of the signal Volts. When navigating the MDB file, we can 
find that the column we are looking for is named: meas_type 
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3. With that information, we can go back into TupePro to modify the INSPECTION DATA table to 

account for this change. 
4. In INSPECTION DATA, a new column is needed to populate with the MDB data. Identify the 

column that will be to the left of the new column, than place your cursor in a cell of that 
column. As follows: 

 
 
If no cell is selected, the new column will be added as the first column and it will be possible to 
change it’s location simply by using the Drag & Drop technique. 

5. To add the column, click on the Insert tool: 

 
6. In the opened menu, enter the desired value. In this case, a Text input is going to be added. The 

Name is the value used by TubePro to sort the data and the Caption is the name that will be 
displayed in the column header. It is advised to use the same Name as the name of the column 
from the data that is going to be imported. Here is the info entered for this example: 
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Click OK. The newly created column will look like this: 

 
7. Now, we need to link the data read to that the new column. To do so, we start by opening 

Import Structure menu: 

 
Than select the Structure of your data and click on Edit: 
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8. In the Data Colum tab, locate the column named like the on in your data, meas_type in this 
case. The third is a drop-down list in which you can select the column in INSPECTION DATA in 
which you want to import the data:  

 
Once the column selected, press ENTER and save the structure before closing it: 

 
Also close the Import Structure Manager 

9. Click on Import & Replace 

 
10. Select the correct data structure from the drop-down list and open it: 
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11. Once imported, the newly added column is populated with the data from the report: 

 
 

7.3 Combining data in one column 

It is possible to combine multiple data in one INSPECTION DATA column. 

1. Create a new column 

 
2. From the Add Column menu, in the Type drop-down list, select Formula: 

 
3. Give a Name and Caption to the column 
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4. Drag & Drop or double click the column names from the Available Fields box you want to 
combine in the Formula Expression box. 

 

8. Printing a map 
These are the steps to take in order to simply create a basic map and print it to bring on site. 

1. Create the map. 

2. Make sure the numbering is adequate. You can use the tools in that section to do so: 
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3. Then, your tube sheet is created. All is remaining is to transfer it to a printable item. 

4. Go to DRAWINGS section on the left menu. 

5. At the top of the page, click on the DRAWING ribbon then select the Page Setup icon. 

6. In the newly opened window, select the paper size. 

 

7. Then select the orientation of the page by clicking on the Margins tab. 
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8. You now have the page format set up. The last thing you need to do is add the Map to that 
page. 

9. To add a map, you simply have to Drag & Drop the 2D Map-All Tubes section views from the 
right side of the view.  

 

10. If you double click on the map, you can edit its appearance.  

11. If you also want to include a legend, you can use the same workflow where you go to the right 
menu, select the Legends Default item and Drag & Drop it to your drawing. When using this 
tool, make sure you press on ENTER when editing a value. Otherwise, the changes might not be 
applied. 

12. Once your page is setup, you can export it to a PDF going to the DRAWING ribbon, then 
clicking on Export. 
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9. Create formula properties 
Formulas can be added to the list of properties that can be used in the software. 

In this example, we will first define a property that will automatically calculate the ID of a tube, than 
create a second one to calculate the fill factor of the probe inside the tube. 

 

1. In the document properties, enter the values for the tube outer diameter (OD) and wall 
thickness (WT). 

2. Write down the actual name of the property, not the caption, to remember it. To verify this 
value: 

o Select a property 

 

o Click Edit icon 

 

o You can find the Name in the newly opened window: 
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o Create a new Property by clicking on the icon Create New Property, than select Other 
Type …: 
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3. In the opened Add Property editor, select Type: -> Formula 
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4. In the Formula Expression section, type the expression you would like to calculate 
automatically. There is no need to add the = sign. In this case for Tube ID, the formula is [Tube 
OD]-2*[Tube Thickness]. 

 

 

o The Tube ID property will now be added to the list of Properties. 

 

o To add the fill factor, here is an example: 
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10. Advanced Inspection Data features 
To display the Inspection Data with more details, it is possible to change the way the data set looks like 
when using the Build PDF Report tool to generate the report. To do so, the advanced features for 
printing the table need to be accessed. Here is the way to access the menu that allows to edit the 
Margins and Header/Footer as well as the page orientation. 

10.1 Editing the header 
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10.2 Choosing the columns to be displayed when printing INSPECTION DATA 

 

1. To access the menu, go to INSPECTIO DATA, in the DATA ribbon and click on Edit report 

 

2. In the window that is now opened, the columns displayed are the ones that will make it in your 
report. 
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3. First, you can choose for your page to be printed in landscape or portrait orientation : 

 
4. After, to set the columns properly, you need to go to the Options ribbon and select the Column 

List tool 

 
5. In the opened window, the list of items are the Column names you can add to your report. To 

add one of them to your report, simply drag and drop them in the header of the report. 

 
6. Once done, close the Customization menu. 
7. Click on OK for the changes to be saved. 
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11. Advanced XLS Report features 
When creating your report, advanced properties are available to simplify your reporting process. 

1. Creating a header 

It is possible to define a header for all of your data pages. First access the print titles menu. 
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Then, select the rows that will keep identical for all your reporting pages. 
 

 
 

  



 

TubePro 5.5 
Version 7 
21-09-13 

 
 
 

45 | P a g e  
  
 

12. Adjust row orientation 
When the user comes across a special tubesheet pattern where the rows are tilted, it is possible 
to set a certain angle for the rows. 
 
1. First, access the Row Direction button. 
 

 

 

2. Click on the screen to mark the starting point of the row used to align the tubes. 
3. Align the line with the desired row direction 
4. Click to set the end point; 
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13. Add percentage values to Legend 
Feature addition allowing to display percentage values next to the tube count within the legend. 

1. Double-click on the legend to modify and open its Legend Editor. 
2. Locate the Include % In Count property. Select Yes from the dropdown menu.  

 
 

3. Press the Entry key  ↵ Return  of your keyboard to confirm the selection. 
4. Click OK to close the Legend Editor and save the changes. 

 
 

14. configure font color for each legend items 
1. Double-click on the legend to modify and open its Legend Editor. 
2. The color font is individually configured for every item of the legend’s content. Select the 

color changing item and click on the Edit button. 
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3. Modify the Value Color field using the dropdown menu. Click OK to save this change.  
 

 
 

4. Click OK to close the Legend Editor and save the changes. Multiple items can be changed 
before closing the Legend Editor.  

5. The result will be as follows: 
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15. Drawing’s font size standardization 
The drwaeings mut be refreshed when font size incoherence appear between drawings in the same 
project. 

1. Double-click on the drawing to open the Multi Section View property window. 
2. Go to the View tab. 

 
 

3. Locate the Font property and click on the  …  button.  
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4. Change the font properties to and click OK.  

 
 

5. Click OK to close the Legend Editor and save the changes. 

6. Click TubePro refresh icon  to update the drawing. This is useful if the same drawing is 
repeated on multiple pages. The pages must be refreshed to display the same 
standardize font.   

 

16. Add a view of the back tubesheet 

In order to change the view direction, click on a Section View, click on the Edit button , go to the 
View tab and change the View Direction row to the desired Direction. 



 

TubePro 5.5 
Version 7 
21-09-13 

 
 
 

50 | P a g e  
  
 

 

 

17. U-bend inspection: Types of link between Top and 
Bottom rows 

 
3 types of inspections can be done for U-bend bundles and is dependent of the type of probe used. 

- Flexible probe: The probe will pass the hot leg, the bend and the cold leg in one shot. And the 
defects will be called for this entire tube. 
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- Candy cane or J-type. The operator will use a flexible probe but will only do one leg and the 
bend in the first pass. Than, once all the top rows are done, they will scan the bottoms legs 
only. This means the TS is 100 tubes and 2 datasets exists for the “same tube”. In this case, 
numbering should not be the mirror from top to bottom. And imported data will be 100 tubes. 

- Straight probe. In this case, the bundle is inspected as it was a normal HX. Top and bottom 
defects are not linked together. 

In all cases, PLG tubes will match, because no matter the inspection is conducted, if top tube needs to 
be plugged, then the bottom one will also be plugged. 

The parameters are located in the Project Browser -> Section Properties 
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18. Using support plates as a reference point to 
position defects 

When adding or modifying defects or indications in Inspection Data, it is possible to determine the 
position of the defects as a distance from a support plate. 

To do so, first we need to tag the support plate of interest with a name determined by the user. This is 
done in the 3D model window, in the Support editor window. 

 

The Tag that can be considered to use as a refernce point is the data on the first colum. In this case, we 
will name the support plate “SP1” 

 

In the 3D model window, Selecting the “Show Part Names” will add the tag of each element on the 3D 
model 
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To show the defects in the 3D model, the “Show defect”  button on Map – Advanced 
window has to be selected. 

When adding a defect via the Inspection Data menu, in the location column, a distance from a support 
plate can be determined by writing TagOfSupportPlate+Distance. 

 

In this case, a 55% pitting will be added at 15” from the support plate that was previously added and 
named: 
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Distances can also be negative from the reference point. Positive direction is from front to back of the 
bundle 
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Additional Note : when adding multiple support plate with the same Tag, and using the tag as a 
reference point for a defect, the defect will consider only the first support plate of the series . 

 

 

 

19. Create a Project Properties data base 
Steps to use an external Excel spreadsheet as a customer database. 

Loading and creating your Excel spreadsheet  

This initial part is only needed when a new Excel file is going to be used. Once we have set it all up, we 
can update the TubePro project by simply loading a newer version of the same spreadsheet we initially 
load. The spreadsheet can also be edited inside of TubePro. 

Add a new Spreadsheet to the project from the Project tab in the Project Browser. 
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Load the XLSX file that has the customer data stored in it. This file can be edited outside of TubePro and 
any changes can be loaded into a project as the file is updated. 

 

The Excel sheet must have the values that you want to associate with a property field. If you want to 
set a list for a field  

Setting up the Linking for texts or lists  

In this example, all the Customers are entered in the B column starting at row 5. We will now link that 
column to the Name project property. 

Select the first cell with customer data in the B column, in this case B5. Then, click on the Property Import 
menu tab and then slick on the 'Link Cell to Property' button. 
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Here you can either link the cell to an existing property or create a new one to link to. We will select the 
'Link To Existing Property' and then select 'Client Name' from the dropdown list. Then select the 'Link List' 
option as the Link Type and click OK. 

 

The program will load all the cells from that column into a list for the Name property. If you click in the 
Name property it should now be a dropdown button on the right side and when you click that all the 
customers are listed (you might have to click on another cell first and then back to the Name property). 
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We can do this for all the fields that we want to get lists or text values from. If the excel file is loaded 
back into the project the fields are automatically updated with the latest data. This process will be 
described later. 

You can also add and edit data directly into the spreadsheet. If you want to add a new customer, you 
can simply add it at the bottom of the other customers in the column. The program looks for items in 
the column until it finds an empty cell. You can also change an existing customer. Every time a linked list 
property field get selected in the Project Property editor the list gets the latest values from the 
spreadsheet.  

The same operations can be done if you want to link a property to a single cell. In this case you can select 
the Link Text option when linking the property. 

 

 

Linking two fields  

It is also possible to change a property field value and then have another field automatically populated 
according to this change. For instance, you can have the client’s name linked to its address. Changing 
the client will automatically change the address. This is done by linking a property to a cell in the 
spreadsheet and linking it to another project property. One requirement for this to work is that the rows 
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for the linked cells are lined up. For example, all the Customers are in column B and all the Addresses are 
in column C. The address and customer should be on the same row. 

To link a property as a ‘Linked field’ the ‘Linked Field’ option is selected from the ‘Link Property to Cell’ 
dialog. Select the property that should act as the row selector for the ‘linked field’. 

 

 

Linking by changing the properties 

An existing property can also be changed by changing its parameters. To access them, click on the 
property that you want to modify in the Project Browser, then click Edit Property button.  

 

 

To link the property to an Excel spreadsheet set the Type to a ‘XLS Linked Field’ type. Set a reference to 
the first cell that the data column is in and finally link to the property that will act as the row selector. 
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You can link multiple properties to a selection property such as Client in the example above. Again, the 
requirement is that each columns data line up with the row of the selection property. 

Save Import template 

To help standardize the procedure within a group of user, it is possible to export the previously set settings. 
Simply go to the Property Import ribbon and click on Save Import Template. This will create a file that 
tells the software where to take the properties values in the Excel spreadsheet. Note that the actual 
Properties are not saved. 

 

 

Import Excel values 

An Import template and the spreadsheet that goes with it can be shared and imported in another project 
that have the same properties fields (for a recent inspection by a colleague for instance). To make this 
import, you can click on the Import Excel Value button and select the Excel file and the Import template. 
Check the Import and update items box to update the properties fields of your project.   
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20. 3D model of a water-tube boiler 
For basic Boiler design: 

1. Create a rectangular Tubesheet in 2D Maps 
2. In the Project Browser -> Unit Type -> Mud and Steam Drum Boiler 

 

3. Basic parameters for the Boiler can be adjusted from the menu: 
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4. For advanced parameters for more complex design, simply select from the drop-down 
menu Specify in Boiler Editor and than select Boiler Editor: 

 
 

5. This menu will give you control over more settings. 

 

 

21. Tube-to-Tube data comparison 
Starting with version 5.5, TubePro offers trending capabilities to assess defects progression between 
inspections. This information can be shown in:  

• A custom column in the inspection data table;  
• Legends and 2D section views;  
• Reports (DOC and XLS).  
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The following steps describe how to configure the Project to display trending values for a Project that 
contains more than one inspection. In the following example, the Project has data for a heat exchanger 
that was inspected initially in 2016 and then again in 2020.   
  

1. From the PROJECT ribbon of any tab, click on the “Inspections” button and select the most 
recent inspection.  

 
  

2. Next, a new column showing the defects progression values must be added to the data 
table. From the INSPECTION DATA tab, in the DATA ribbon, click on the “Insert” button to 
add a new column.  

  
  

3. The Column editor window must be configured as shown on the image below.  
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a. Type: Select “Formula”  
b. Unit: Select “None”  
c. Name: Name of the property  
d. Format: Select “%”  
e. Caption: Text appearing in this data table column’s header  

Formula Expression: The progress of the defects is calculated by doing the subtraction 
of the depth value in percent of both inspections. It is important to write the formula as 
shown in the example below, using the brackets and exclamation marks.   
  

[MoreRecentInspectionName!Percent]-[OlderInspectionName!Percent]  
  
In this example, it would correspond to the following: [2020!Percent]-[2016!Percent]  

  
4. Once the Column Editor window is configured, click on OK. The table now contains the new 

“Progress” column. In this example, you can notice that the tube 004-006 now has a defect 
with a depth of 50%, with a progress of 20% compared to the 2016 inspection.   
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5. The following steps describe how to show the trending on a Legend and 2D drawing. 
First, create a new legend.  
 

6. Open the Legend Editor menu of the newly created Legend. Type a relevant name.  
 

7. For the Inspection, select the most recent of the two inspections that are being compared. 
It also corresponds to the inspection in which the column has been added in the data 
table.  
 

8. Add a new counter.  
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9. In the Counter Editor, fill the fields with the desired information. In the “Conditions to be 
met” field, select the name of the trending property that has been added at one of the 
previous steps, in this example “Progress”.  

 
  

10. Add other counters if needed. When done, click on OK.   

 
  

11. Drag and drop the legend to a drawing.  
 

12. Create a new 2D map tube section view and open the Editor. Under the View tab of the 
Editor, Select the newly created Legend.  
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13. Drag and drop the tube section view to the drawing.  

 
  

14. Finally, the trending values can be added to a report. These items can be found in the DOC 
– REPORTS or XLS – REPORTS, in the Project Browser, under the Macros tab. You 
simply have to drag and drop them in the report.   
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22. Inspected Length 
The total inspected length property or macro returns the cumulative length of all the inspected tubes in 
an inspection, i.e. all the tubes for which a defect has been added (Percent column of the Inspection 
Data table) and those marked as NDD. IMPORTANT: All the other codes are not considered for the 
total inspected length. 
 

1. From the INSPECTION DATA section, in the PROJECT ribbon, click on the Inspections button 
and click on Properties. The total inspected length is shown in this menu.  

 
  

2. The Total Inspected Length can also be added to Drawings or Reports from the Macros tab 
of the Project Browser. To add it, simply drag and drop this item to a drawing or a report.  
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3. Lastly, the Total Inspected Length can be added to a Legend. Here are the steps to follow:  
a. From the Project Browser of the Drawings section, click on the Project tab, select 

the legend to edit and click on the Edit button.  
b. From the Legend editor, click on Add and then New Macro.  

 
c. Fill the Macro editor as shown on the image below. Grab the INSPECTED_LENGTH 

item from the available counters list and drag it to the Script/Formula section. 
When completed, click on OK.  
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d. Back in the Legend editor window, select the added macro and use the Move Up 

and Move Down buttons to change its position in the Legend. Click on OK.  

 
e. Here is the resulting legend with added inspected length information:  
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